Author Topic: Visibility states - I don't get it  (Read 20292 times)

0 Members and 1 Guest are viewing this topic.

Mr Cory

  • Guest
Re: Visibility states - I don't get it
« Reply #15 on: June 06, 2007, 05:33:34 PM »
Great! Thanks! At least now I won't waste any more time on it.  I am using 2008 also, those guys at Augi made these look so easy so I was trying to turn some of my old wblocks into dynamic blocks. Thanks for the help.

Kim, you had set your block up perfectly you difinatly heading in the right direction :-) Just select all your attributes and under the properties change "lock in position" from no to yes, youll be sweet

kim

  • Guest
Re: Visibility states - I don't get it
« Reply #16 on: June 06, 2007, 05:39:32 PM »
That did it!! Thank you so much!

Mr Cory

  • Guest
Re: Visibility states - I don't get it
« Reply #17 on: June 06, 2007, 05:41:22 PM »
Happy to help  :-)

daron

  • Guest
Re: Visibility states - I don't get it
« Reply #18 on: June 06, 2007, 05:42:13 PM »
I tried to lock them. That didn't work either.

Mr Cory

  • Guest
Re: Visibility states - I don't get it
« Reply #19 on: June 06, 2007, 05:48:45 PM »
In kim's block or your own?

kim

  • Guest
Re: Visibility states - I don't get it
« Reply #20 on: June 06, 2007, 05:58:18 PM »
Mine didn't work at first but I erased all the existing one's out of my drawing and re-inserted it and it worked fine. 

Mr Cory

  • Guest
Re: Visibility states - I don't get it
« Reply #21 on: June 06, 2007, 06:01:19 PM »
Sorry i should of mentioned that tanks Kim, you need to re-insert the block for it to work, once a block is inserted with attributes they are set as they are, so if you change the attributes in block editor the attributes of the blocks already inserted wont take on the new changes

ronjonp

  • Needs a day job
  • Posts: 7527
Re: Visibility states - I don't get it
« Reply #22 on: June 06, 2007, 06:13:40 PM »
You need to change the attributes to "lock position"

Dynamic blocks wont touch attributes that arent, id say that is where alot of problems are coming from. If you need them to be moved around freely create a point param with a move

I thought that only applied to move\stretch parameters? With visibility states it has no effect.....unless I'm missing something obvious.

Ron

Windows 11 x64 - AutoCAD /C3D 2023

Custom Build PC

Mr Cory

  • Guest
Re: Visibility states - I don't get it
« Reply #23 on: June 06, 2007, 06:17:16 PM »
I believe its the same for vis states, it worked fine @ my end and thats all i had to do

Kim, what in the point parameter for?

ronjonp

  • Needs a day job
  • Posts: 7527
Re: Visibility states - I don't get it
« Reply #24 on: June 06, 2007, 06:19:18 PM »
In the block editor it works over here...but when you go back into modelspace and test it, they are always on??

Windows 11 x64 - AutoCAD /C3D 2023

Custom Build PC

Mr Cory

  • Guest
Re: Visibility states - I don't get it
« Reply #25 on: June 06, 2007, 06:21:14 PM »
O i c, you'll need to insert it again,
Sorry i should of mentioned that tanks Kim, you need to re-insert the block for it to work, once a block is inserted with attributes they are set as they are, so if you change the attributes in block editor the attributes of the blocks already inserted wont take on the new changes

ronjonp

  • Needs a day job
  • Posts: 7527
Re: Visibility states - I don't get it
« Reply #26 on: June 06, 2007, 06:22:20 PM »
When in doubt....reinsert  :-D

Windows 11 x64 - AutoCAD /C3D 2023

Custom Build PC

Mr Cory

  • Guest
Re: Visibility states - I don't get it
« Reply #27 on: June 06, 2007, 06:25:17 PM »
Haha exactly! Dont forget "resetblock" it doesnt apply in this case but its quite handy when dealing with parameters, not so much attributes

ronjonp

  • Needs a day job
  • Posts: 7527
Re: Visibility states - I don't get it
« Reply #28 on: June 06, 2007, 06:32:36 PM »
It would be nice to have a "Insert Attribute Text Parameter" then you could create a visibility parameter that filled in the attributes with predefined text rather than stacking multiple text objects on each other.

Windows 11 x64 - AutoCAD /C3D 2023

Custom Build PC

kim

  • Guest
Re: Visibility states - I don't get it
« Reply #29 on: June 06, 2007, 06:33:49 PM »
The point perameter was just so I could see if I could make it work.  I wanted to test out the multiple insertion point thing (the ctrl key toggles through them) because sometimes on a detail the elevation is on the left and sometimes its on the right.  I can toggle through the insertion points if I just insert the block from the pull-down menu, but if I drag the block to a palette and then insert it, it won't toggle through the insertion points. Is there a way to get past that?