Author Topic: Stretching issue with dynamic blocks  (Read 5063 times)

0 Members and 1 Guest are viewing this topic.

Barry Clark

  • Guest
Stretching issue with dynamic blocks
« on: October 04, 2006, 09:32:24 AM »
I made a dynamic block that I intend to have a stetch action associated with. It has two lines and an attribute. The two lines are parallel 2.5" apart and the attribute is simplex text at 2.25" tall and centered between the lines. Now, I place a linear attribute aliong the length of one of the lines and give it only one arrow. The first stretch action is for the lines and the stretch area covers most of the lines. This works fine. Next, using the same linear attribute, I attach another stretch action to the attribute with a multiplier of 0.5 so that it only moves have the distance of the stretch. What happens, though, is that the attribute text doesnt' move at all. Should I change the action to a move or am I just screwing up the stretch?

Barry Clark

  • Guest
Re: Stretching issue with dynamic blocks
« Reply #1 on: October 04, 2006, 10:08:04 AM »
Works with text, but not with attributes. Any thoughts?

Dave R

  • Guest
Re: Stretching issue with dynamic blocks
« Reply #2 on: October 04, 2006, 12:38:14 PM »
Set the Lock Position property of the attribute to Yes.

Works with text, but not with attributes. Any thoughts?

daron

  • Guest
Re: Stretching issue with dynamic blocks
« Reply #3 on: October 04, 2006, 01:27:11 PM »
That's what I was going to suggest. Atts can be a bane to dynamic blocks.

Barry Clark

  • Guest
Re: Stretching issue with dynamic blocks
« Reply #4 on: October 04, 2006, 02:02:13 PM »
Tried switching that about. That didn't work.

What I did, was I applied a move action to the linear parameter with a multiplier of 0.5. It stayed put locked and was filtered out unlocked. Anyone had any success with getting attributes to move about in a dynamic block?

T.Willey

  • Needs a day job
  • Posts: 5218
Re: Stretching issue with dynamic blocks
« Reply #5 on: October 04, 2006, 02:23:16 PM »
Works with text, but not with attributes. Any thoughts?
One point of insight on this, and the reason why it works with text and not attributes (maybe).  Attributes are their own objects, but are associated with the block once it's inserted.  Text objects are resident in the blocks definition, and not their own objects (once the block is inserted).  So the text will move, and the attributes will not.

If this is the case, I think it is poor design on Adesk side.  I don't use dy. blocks right now, so I wouldn't even know how to test your problem really.

Sorry couldn't be more help.
Tim

I don't want to ' end-up ', I want to ' become '. - Me

Please think about donating if this post helped you.

Dave R

  • Guest
Re: Stretching issue with dynamic blocks
« Reply #6 on: October 05, 2006, 08:26:49 AM »
Try using a stretch action instead of a move. If you want to, post the block so we can take a look at it.