Author Topic: Graphic Scale Bar on Tool Palette Problem  (Read 12610 times)

0 Members and 1 Guest are viewing this topic.

Jeff H

  • Needs a day job
  • Posts: 6150
Re: Graphic Scale Bar on Tool Palette Problem
« Reply #15 on: April 10, 2014, 08:53:38 PM »
Or post the dwt you are using to create them.

MP

  • Seagull
  • Posts: 17750
  • Have thousands of dwgs to process? Contact me.
Re: Graphic Scale Bar on Tool Palette Problem
« Reply #16 on: April 10, 2014, 09:04:54 PM »
Engineering Technologist CAD Automation Practitioner
Automation ▸ Design ▸ Drafting ▸ Document Control ▸ Client
cadanalyst@gmail.com http://cadanalyst.slack.com http://linkedin.com/in/cadanalyst

Jeff H

  • Needs a day job
  • Posts: 6150
Re: Graphic Scale Bar on Tool Palette Problem
« Reply #17 on: April 10, 2014, 09:07:48 PM »
If that block was created with base template loaded up earlier someone with verticals has opened and saved it.

It is full of dictionaries created by verticals

T-Square

  • Guest
Re: Graphic Scale Bar on Tool Palette Problem
« Reply #18 on: April 11, 2014, 01:27:14 PM »
Ok, so here is what I think has happened. Someone, not naming any names here...hahaha... apparently opened a template with a newer version of AutoCAD(2013 or 2014) and "overwrote" the default "acad.dwt" using the new program. Then, downgraded back to AutoCAD 2012, but still using the "acad.dwt" created with the newer version. Consequently, I can not purge the "Phantom" linetype because it is tied to a "section" style that is a new bell/whistle in the newer version. So, I have to find a way of getting this cleaned up without ticking off the IT guy to ask for a clean install of AutoCAD 2012.

Too many chefs in the kitchen....

I will see if I can work this out.

T-Square

  • Guest
Re: Graphic Scale Bar on Tool Palette Problem
« Reply #19 on: April 11, 2014, 03:23:39 PM »
Ok, I think I figured it out.

AEC objects. Turned off... "disabled" Object ARX Applications, created some plain linework, used that as the block on the tool palette and I don't get the "Phantom" linetype loading issue. This means I have to re-create all of the blocks with a non-AEC-contaminaited drawing so that I don't get the issue. I noticed the loading of AEC objects when I selected one of the blocks from the tool palette and that is what led me to believe there were AEC objects embedded in one of the blocks.

Funny how you get better at creating a block when you do it several times. hahahaha

Thanks for all of the responses folks. TheSwamp folks are simply the best.

Jeff H

  • Needs a day job
  • Posts: 6150
Re: Graphic Scale Bar on Tool Palette Problem
« Reply #20 on: April 11, 2014, 04:32:06 PM »
You get that from how autocad treats inserting a file as a block it uses the database vs a library file where it only clones the blockdefition from the file.

T-Square

  • Guest
Re: Graphic Scale Bar on Tool Palette Problem
« Reply #21 on: April 11, 2014, 06:47:45 PM »
I guess I don't know what is going on after all. Geez louise. I thought I had it nailed down and it is still doing the exact same thing.

FYI:
NONE of the lisp routines that are loaded via the ACADDOC.lsp do anything with linetypes, blocks, templates or anything else that might cause this issue.

I inserted the first block... "DETAIL-TITLE-BAR", no problem, inserted the second block... "DETAIL-BAR-NO-BUBBLE" and I get the loading of the phantom linetype. It does not matter which block I use first or second.

I have attached the "dwg" that I used to start ALL of my blocks, the blocks themselves and screen shots of one of the palette config and my text screen.

What in the heck am I doing wrong?

Update: I do not get the "Phantom" linetype trying to load when I just insert the block or use the menu pulldown I have coded up. Is it the tool palette itself?

« Last Edit: April 11, 2014, 07:19:18 PM by T-Square »

Crank

  • Water Moccasin
  • Posts: 1503
Re: Graphic Scale Bar on Tool Palette Problem
« Reply #22 on: May 06, 2014, 01:25:13 PM »
I bet it's in the tool properties of the block on the toolpalette:
In your .zip-file there is a preview of the tool properties of the block DETAIL-TITLE-BAR.
But you should look at the tool properties of the block DETAIL-TITLE-BAR-NO-BUBBLE, because that's when it goes wrong. > General > Linetype > Change PHANTOM to 'use current'.
Vault Professional 2023     +     AEC Collection