Author Topic: Is anyone here using GstarCAD?  (Read 2966 times)

0 Members and 1 Guest are viewing this topic.


  • Newt
  • Posts: 135
Is anyone here using GstarCAD?
« on: February 12, 2022, 10:23:00 AM »
I used the 2020 version. Saw lots of potential but a few minor to moderate bugs basically barred me from using it for anything profitable. The 2022 version seems a lot better, but still need to test it out a bit more.

It's Alive!

  • Retired
  • Needs a day job
  • Posts: 8581
  • AKA Daniel
Re: Is anyone here using GstarCAD?
« Reply #1 on: February 13, 2022, 07:26:13 PM »

Iíve tried it from an API perspective. Their GRX implementation is one of the fastest of the clones, but I only tested the things I was working on.
Though the API is not yet complete. I didnít try lisp. I donít know how much you rely on apps.

I contacted support and they were responsive.

The GUI looks good. Panning and zooming is fast.

Code - C: [Select]
  1. testname ZRX create tin  277.826200
  2. testname ZRX create tin  2127.325200
  4. testname GRX create tin  276.886000
  5. testname GRX create tin  2035.433400
  7. testname BRX create tin  1245.017900
  8. testname BRX create tin  8768.967900
  10. testname GRX create tin undo  255.748200
  11. testname GRX create tin undo  1840.230100
  13. testname ZRX create tin undo  409.248100
  14. testname ZRX create tin undo  3090.678700
  16. testname BRX create tin undo  1623.380100
  17. testname BRX create tin undo  11653.328300


  • Newt
  • Posts: 135
Re: Is anyone here using GstarCAD?
« Reply #2 on: March 18, 2022, 12:21:36 AM »
Thanks for sharing!!

There upgrade is currently on sale. Actually never buy full price as they frequently have sales.

I used it a little more. Still impressed but it does crash often. It crashes noticeably more often than ACAD but not enough to render it un-useable. The CUI is very unstable (as was 2020's).

Some of my LISP that worked in 2020's doesn't work in 2022. Any function that uses the layer object (vla-get-layers) fails; no error just doesn't perform the task. Also, all of my command names using the '`' key (the one to the left of the '1' key) don't work anymore. It's kind of a unique workflow I developed so I might be the only person on earth affected by this  :2funny: . I'm more concerned about the vla-get-layers thing because that insinuates that they're messing with the API somehow (not good!!).

With the 2020 support was very responsive at first. I shared my first round of bugs. My second round of bugs... not as responsive... but also they fixed everything I found since then (which was probably a lot of work).

In spite of the above I would probably still pay to upgrade if I wasn't so busy right now. I also need VLIDE. It is very fast and light so I might have another go at it in '23 or '24 though.