Author Topic: HTML Opens in Internet Explorer, not Edge  (Read 1283 times)

0 Members and 1 Guest are viewing this topic.

KKirk

  • Mosquito
  • Posts: 3
HTML Opens in Internet Explorer, not Edge
« on: May 13, 2024, 04:04:46 PM »
I'm working on a Dialog that will show a webpage, but when the dialog navigates to the URL it comes up as a page prompting me to upgrade my browser to Edge (It's a sharepoint page which apparently won't display on Explorer). Is there a way to have the HTML box display as an Edge browser and not Explorer?

Lonnie

  • Newt
  • Posts: 200
Re: HTML Opens in Internet Explorer, not Edge
« Reply #1 on: May 13, 2024, 04:50:06 PM »
I think all you'll have to do is change your default application for opening that type of file.
Open the Start menu type for Default apps
Find the app you want to launch things in then add the extension type to the list.

KKirk

  • Mosquito
  • Posts: 3
HTML Opens in Internet Explorer, not Edge
« Reply #2 on: May 14, 2024, 08:34:01 AM »
Edge is set as my default browser, I don't think that's the issue. I don't even have explorer on my PC. Tried changing the default to chrome to see if that changed anything, no luck there.

It's Alive!

  • Retired
  • Needs a day job
  • Posts: 8926
  • AKA Daniel
Re: HTML Opens in Internet Explorer, not Edge
« Reply #3 on: May 14, 2024, 08:55:11 AM »
ask Owen to add acedShowHTMLModalWindow and acedShowHTMLModelessWindow
it's AutoCAD only though, uses autocad's internal chrome

MickD

  • King Gator
  • Posts: 3684
  • (x-in)->[process]->(y-out) ... simples!
Re: HTML Opens in Internet Explorer, not Edge
« Reply #4 on: May 14, 2024, 05:48:19 PM »
I'm working on a Dialog that will show a webpage, but when the dialog navigates to the URL it comes up as a page prompting me to upgrade my browser to Edge (It's a sharepoint page which apparently won't display on Explorer). Is there a way to have the HTML box display as an Edge browser and not Explorer?

What web view control are you using? If you're using the old WebBrowser control you may get these issues as the html engine is pretty old. The most up to date control is WebView2, it takes a bit more to set up but works well and is based on the Edge engine so that should work.
"Programming is really just the mundane aspect of expressing a solution to a problem."
- John Carmack

"Everything that is possible demands to exist"
- Gottfried Wilhelm von Leibniz

DW

  • Newt
  • Posts: 25
Re: HTML Opens in Internet Explorer, not Edge
« Reply #5 on: May 17, 2024, 12:59:26 AM »
You could try setting an Internet Explorer registry entry to specify the MSIE User-Agent. Not sure if this will clear up issues on a sharepoint page but prevents a lot of script errors which would otherwise pop up.

By default it's not set when AutoCAD is installed (but is for BricsCAD).

The key can be checked and set with the following code:
CodeSelect
(if (not (vl-registry-read "HKEY_CURRENT_USER\\Software\\Microsoft\\Internet Explorer\\Main\\FeatureControl\\FEATURE_BROWSER_EMULATION" (strcat (getvar "program") ".exe")))
      (vl-registry-write "HKEY_CURRENT_USER\\Software\\Microsoft\\Internet Explorer\\Main\\FeatureControl\\FEATURE_BROWSER_EMULATION" (strcat (getvar "program") ".exe") 11001)
  )

Where the 11001 DWord value will force IE11 emulation instead of an older IE emulation.

More info here: https://www.devhut.net/webbrowser-activex-control-google-maps-invalid-character-scripting-error/

KKirk

  • Mosquito
  • Posts: 3
HTML Opens in Internet Explorer, not Edge
« Reply #6 on: June 18, 2024, 01:17:24 PM »
Thanks for all of the input. Unfortunately, this project got put on the backburner for now. I will dig in with these suggestions when I have an opportunity to jump back in.