Author Topic: Windows Explorer Woes  (Read 3349 times)

0 Members and 1 Guest are viewing this topic.

ronjonp

  • Needs a day job
  • Posts: 7529
Windows Explorer Woes
« on: January 15, 2004, 10:30:16 AM »
Not really CAD related but this has been bugging me for a while.....In windows explorer I can't get the folders to open in the same window. I've gone to Tools>Folder Options>General>and checked "open each folder in same window". They will open fine if I go to View>Explorer Bar>and set it to folders.....but I have to browse on the explorer bar side. If I click on the folders to the right of the explorer bar they open up in a separate window! This all happened after I added a register dll to my right click using this --->REGEDIT4
 
[HKEY_CLASSES_ROOT\dllfile\shell\RegDLL]
@="Re&gister DLL"
 
[HKEY_CLASSES_ROOT\dllfile\shell\RegDLL\command]
@="regsvr32 %1"
 
[HKEY_CLASSES_ROOT\dllfile\shell\UnregDLL]
@="&Unregister DLL"
 
[HKEY_CLASSES_ROOT\dllfile\shell\UnregDLL\command]
@="regsvr32 /u %1"


Does anyone have any suggestions on how to fix this....I'm out of ideas and patience.

Thanks,

Ron

BTW.....running XP Pro

Windows 11 x64 - AutoCAD /C3D 2023

Custom Build PC

Keith™

  • Villiage Idiot
  • Seagull
  • Posts: 16899
  • Superior Stupidity at its best
Windows Explorer Woes
« Reply #1 on: January 15, 2004, 10:39:21 AM »
Well, explorer SHOULD never open the folder in a new window even if the option is selected. Unless of course that is a new "feature" of XP that I am not aware of...
Proud provider of opinion and arrogance since November 22, 2003 at 09:35:31 am
CadJockey Militia Field Marshal

Find me on https://parler.com @kblackie

Craig

  • Guest
Windows Explorer Woes
« Reply #2 on: January 15, 2004, 11:00:12 AM »
You must have changed something to make it do that. I use XP pro and mine only opens in the original window.
Have you tried removing you register dll's to see if it goes back to normal?

ronjonp

  • Needs a day job
  • Posts: 7529
Windows Explorer Woes
« Reply #3 on: January 15, 2004, 03:05:36 PM »
If anybody cares.......

I got it. These are the keys that control how the folders open (got hosed somehow and moved from default):

Code: [Select]
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Folder\shell\open]
"BrowserFlags"=dword:00000010
"ExplorerFlags"=dword:00000012

[HKEY_CLASSES_ROOT\Folder\shell\open\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
  00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
  65,00,20,00,2f,00,69,00,64,00,6c,00,69,00,73,00,74,00,2c,00,25,00,49,00,2c,\
  00,25,00,4c,00,00,00

[HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec]
@="[ViewFolder(\"%l\", %I, %S)]"
"NoActivateHandler"=""

[HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec\application]
@="Folders"

[HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec\ifexec]
@="[]"

[HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec\topic]
@="AppProperties"


I also had to delete this entry:

Code: [Select]
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\shell\explore]

[HKEY_CLASSES_ROOT\Directory\shell\explore\command]
@="explorer.exe \"%1\""

Windows 11 x64 - AutoCAD /C3D 2023

Custom Build PC