Author Topic: PDF PLOTS LARGE UNRESPONSIVE FILES  (Read 258 times)

0 Members and 1 Guest are viewing this topic.


  • Newt
  • Posts: 59
« on: November 29, 2016, 07:19:36 am »
Hi all,

I'm experiencing an issue with the publish to pdf from the sheetset manager - either using the publish dialog box, or using the publish to pdf presets for the current sheetset.

An example - plotting lighting and power layouts, all tabs from the same drawing. The lighting plots ~ 300kb but some of the power layouts rock in at nearly 5mb.
I've tested this using the normal plot dialog (ctrl+p) and setting .dwg to .pdf and the result is the same.

My colleague who is using LT 2017 opens the same SSM file and used the same embedded publish to pdf plotting and all of the plots, be they lighting or power sheets, come in under 500kb.

I've had a look about on the web and haven't found anything definitive. Only thing that's changed recently is installing a recent autodesk update for Acad 2017.

I've tried swapping the .dwg to .pdf .pc3 for one off my colleagues machine and the result is that same. Any ideas what might be happening? This appears to be happening over any project that I open and attempt to plot to pdf.

Acad 2017


  • Newt
  • Posts: 59
« Reply #1 on: November 29, 2016, 10:53:23 am »
I thought I'd give some background on this and some more information for other users should they encounter the same issue.

This problem has been going on for a week or two now. Pdf plotting has become un-useable on my machine using Acad2017. A previous install Acad2016 works fine. I've attached an image of one of our project folders showing a drawing over a couple of revisions. You will see the size problem.

I tried the following:
  • restoring the software to its default settings - using the 'reset to default' in the start menu
  • Performing a 'hard reset' of the software by deleting registry entries for autocad then removing the roaming user profile for the same

I was expecting my next task to be a complete unistall/re-install of AutoCAD.

However, after some thought, I focussed on the recent update.

Autodesk Auto CAD 2017.1.1 English Update

Once I had removed this using windows add/remove programs / updates, functioning of the pdf plotting/publishing returned to normal (so far).

I have reported this to Autodesk through my account management panel and raised a service ticket with them.

Until this is resolved neither I, or my colleague, will be installing any further updates to our software.
I don't know if mods / admin could sticky this for the rest of the forum; I found no information online about this, granted it could be a problem related to my machine only, but it was sufficiently annoying for me to spend most of the day tinkering and searching for an answer to this.

Acad 2017


  • King Gator
  • Posts: 3584
  • Take a little time to stop and smell the roses.
« Reply #2 on: November 29, 2016, 07:03:56 pm »
I've always hated that response because it was usually followed by, "I don't have time for that right now."
Senior Mechanical Designer/Model Manager
Building Systems


  • Newt
  • Posts: 59
« Reply #3 on: November 30, 2016, 04:09:33 am »
I think of all the little niggles I've had with autocad software over the years, those related to plotting have caused me the most stress. More often than not, when we need a tonne of drawings issued, multiple copies and sheets, on a friday at ~2pm (we finish at 4 here) is when things head south in a hurry.

It's like cad knows...

Acad 2017


  • King Gator
  • Posts: 3723
« Reply #4 on: November 30, 2016, 10:39:58 am »
I had a similar issue back when first adopting 2016... The behavior I observed was that even though I used DWG to PDF, I'd get a different resultant file size, and PDF settings (i.e., Layers, etc.) when printing the PDF in different ways (i.e., Autopublish, Plot, Publish, PdfExport, etc.).

What I found, was that in 2016 version Autodesk hard-coded some of the plotting mechanisms to use one of their new PDF driver, even when a named Page Setup specifies DWG to PDF driver.

What I did to fix this -

Go through your local copies of  their new "AutoCAD PDF (<SomeDescription>).pc3" files, make a BAK copy of the originals, and then try setting all of those PC3 files to your desired DWG to PDF settings... Assuming the default Printer Configuration Search path in Options, that would be here:

Code - Auto/Visual Lisp: [Select]
  1. (startapp "explorer" (strcat (getvar 'roamablerootprefix) "Plotters"))

HTH, Cheers
"Potential has a shelf life." - Margaret Atwood


  • Newt
  • Posts: 59
« Reply #5 on: December 13, 2016, 10:08:24 am »
Thought I'd supply some more information on this.

At the request of autodesk, I tried the update once again, only to produce the same results.

I emailed them the outcome of my further testing and have received a reply confirming that this is a known issue that the development team are looking in to, with a view to see if a fix can be provided in a future update.

possible workarounds are as follows:

Edit the PDF Options in AutoCAD and enable the setting "Include Hyperlinks."

Alternatively, uninstall the AutoCAD 2017.1.1 update via Programs and Features > View Installed Updates.

I've not tried the pdf hyperlink option. But I'll say that uninstalling the 2017.1.1 update removes the problem I was having.
« Last Edit: December 14, 2016, 03:14:54 am by jumpy »
Acad 2017