Author Topic: XREF MText Background Shown As Solid Fill?  (Read 712 times)

0 Members and 1 Guest are viewing this topic.

BlackBox

  • King Gator
  • Posts: 3735
XREF MText Background Shown As Solid Fill?
« on: March 28, 2016, 10:59:40 am »
Does anyone know the cause for why all XREF Dimensions, MText, and MLeaders with background fill enabled (as background color) would start showing up as solid fill, as in I cannot see the text contents?

Again, only the XREF-ed annotations; I have annotations within the current drawing with same background fill enabled (as background color), and they look/plot as expected.

When I open the source XREF, they appear normally (as background color), and only XREF annotations to that drawing show as solid fill.

I've audited, and recovered the XREFs, and nothing changes - they still show up as a color filled rectangle, and plot solid black. :|
"Potential has a shelf life." - Margaret Atwood

BlackBox

  • King Gator
  • Posts: 3735
Re: XREF MText Background Shown As Solid Fill?
« Reply #1 on: March 28, 2016, 11:10:10 am »
Opened the same drawing(s) in 2015 (using 2016 above), and there's no issue - so this seems to be an application setting.
"Potential has a shelf life." - Margaret Atwood

mjfarrell

  • Seagull
  • Posts: 13920
  • Every Student their own Lesson
Re: XREF MText Background Shown As Solid Fill?
« Reply #2 on: March 28, 2016, 11:16:36 am »
what is your view type?

2d wireframe?  or what?
Be your Best


Michael Farrell
http://primeservicesglobal.com/

BlackBox

  • King Gator
  • Posts: 3735
Re: XREF MText Background Shown As Solid Fill?
« Reply #3 on: March 28, 2016, 11:20:44 am »
Found the culprit... XREFOVERRIDE == 1

How/why would that cause annotation background fills (as background color) to show as being solid color fill? *confused*
"Potential has a shelf life." - Margaret Atwood

mjfarrell

  • Seagull
  • Posts: 13920
  • Every Student their own Lesson
Re: XREF MText Background Shown As Solid Fill?
« Reply #4 on: March 28, 2016, 11:22:32 am »
The XREFOVERRIDE system variable affects display and plotting, and works in conjunction with the VISRETAIN system variable. If you want the xref layers to retain their original layer settings, it is recommended to set VISRETAIN and XREFOVERRIDE system variables to 0.
0   When the properties of the objects (such as color, linetype, lineweight, transparency, or plot style) on the external reference drawing are set to ByLayer, any changes to the xref layer properties are displayed in the current drawing (legacy behavior)
1   When the visual properties of the objects on the external reference drawing are not set to ByLayer, objects on xref layers are treated as if their properties are set to ByLayer and every external reference layer can have its own set of layer overrides
Be your Best


Michael Farrell
http://primeservicesglobal.com/

mjfarrell

  • Seagull
  • Posts: 13920
  • Every Student their own Lesson
Re: XREF MText Background Shown As Solid Fill?
« Reply #5 on: March 28, 2016, 11:23:42 am »
Found the culprit... XREFOVERRIDE == 1

How/why would that cause annotation background fills (as background color) to show as being solid color fill? *confused*

It would appear that those background masks are NOT a BYLAYER setting...at least as far as autocad is concerned, so they get whacked
Be your Best


Michael Farrell
http://primeservicesglobal.com/

BlackBox

  • King Gator
  • Posts: 3735
Re: XREF MText Background Shown As Solid Fill?
« Reply #6 on: March 28, 2016, 11:24:49 am »
I've read the help - what I don't understand is why masking is included?

Setting the background fill to ByLayer pretty much defeats the purpose of having a mask enabled in the first place, as not even the text within can be seen.
"Potential has a shelf life." - Margaret Atwood

mjfarrell

  • Seagull
  • Posts: 13920
  • Every Student their own Lesson
Re: XREF MText Background Shown As Solid Fill?
« Reply #7 on: March 28, 2016, 11:31:15 am »
I've read the help - what I don't understand is why masking is included?

Setting the background fill to ByLayer pretty much defeats the purpose of having a mask enabled in the first place, as not even the text within can be seen.
Yeah well, not everything those folks at autodesk dreams up works the way we would like it to, nor does it always work the way they intended it to either...

a good example, Sheet Sets, when first introduced they claimed on could use things like repetitive details sheets over and over in multiple sets...
then it later turns out, OOPS  no you cant, without making a copy of the dumb sheet, which is what SSM was supposed to help you stop doing...
by the way, it's still broken and they want us to accept it that way
Be your Best


Michael Farrell
http://primeservicesglobal.com/

BlackBox

  • King Gator
  • Posts: 3735
Re: XREF MText Background Shown As Solid Fill?
« Reply #8 on: March 28, 2016, 11:38:27 am »
Thanks anyway, Michael - just glad to get it fixed at this point (by setting XREFOVERRIDE == 0).
"Potential has a shelf life." - Margaret Atwood

mjfarrell

  • Seagull
  • Posts: 13920
  • Every Student their own Lesson
Re: XREF MText Background Shown As Solid Fill?
« Reply #9 on: March 28, 2016, 11:49:51 am »
of interest The XREFOVERRIDE system variable seems to be set to 0 (off) by default.

Perhaps it has been set to 1 (on) in your template(s)?
Be your Best


Michael Farrell
http://primeservicesglobal.com/

BlackBox

  • King Gator
  • Posts: 3735
Re: XREF MText Background Shown As Solid Fill?
« Reply #10 on: March 28, 2016, 01:06:04 pm »
of interest The XREFOVERRIDE system variable seems to be set to 0 (off) by default.

Perhaps it has been set to 1 (on) in your template(s)?

No - just futzing around last Thursday to see if this would be of benefit, and it clearly is not (to me, at this time), for the reasons above. I was on vacation Friday, and neglected to change it back before I left. Didn't affect 2015, as it didn't exist. :-)
"Potential has a shelf life." - Margaret Atwood

Jeff H

  • Needs a day job
  • Posts: 5705
Re: XREF MText Background Shown As Solid Fill?
« Reply #11 on: March 29, 2016, 04:50:42 am »
had problems causing text with fields unusable in xref with it set to 1. Had to turn off field display



mjfarrell

  • Seagull
  • Posts: 13920
  • Every Student their own Lesson
Re: XREF MText Background Shown As Solid Fill?
« Reply #12 on: March 29, 2016, 08:35:47 am »
looks like dev team never bothered to test this 'new' tool in the real world

otherwise we would not be fighting these obvious (to us) undesirable effects

Be your Best


Michael Farrell
http://primeservicesglobal.com/

Mark

  • Custom Title
  • Administrator
  • Seagull
  • Posts: 27835
Re: XREF MText Background Shown As Solid Fill?
« Reply #13 on: March 29, 2016, 08:38:59 am »
looks like dev team never bothered to test this 'new' tool in the real world

otherwise we would not be fighting these obvious (to us) undesirable effects
Honestly, you should totally blame all the beta testers. That is just a total lack of their part. *sigh*
TheSwamp.org  (serving the CAD community since 2003)

mjfarrell

  • Seagull
  • Posts: 13920
  • Every Student their own Lesson
Re: XREF MText Background Shown As Solid Fill?
« Reply #14 on: March 29, 2016, 09:03:41 am »
looks like dev team never bothered to test this 'new' tool in the real world

otherwise we would not be fighting these obvious (to us) undesirable effects
Honestly, you should totally blame all the beta testers. That is just a total lack of their part. *sigh*

I might be inclined to, except without know what the testers were asked to test...it could be that no one asked them to look for this particular behavior
and it got overlooked

however IF anyone here was on that beta testing team, I will wait for their comments before drawing any conclusions about testing and or performance metrics, and their efforts
to test this feature/function
Be your Best


Michael Farrell
http://primeservicesglobal.com/

BlackBox

  • King Gator
  • Posts: 3735
Re: XREF MText Background Shown As Solid Fill?
« Reply #15 on: March 29, 2016, 01:31:42 pm »
No beta testers are going to be able to comment on anything specific, as it would violate NDA.



That said, as a beta tester myself -

All I will say is that there was enough broken in 2016 that I still haven't deployed it to my users, and only recently bothered to install it for myself (+/- Thanksgiving 2015? Some time after SP2), to see if the more critical items had yet been fixed.

That is why I only attempted to use XREFOVERRIDE last week for the first time. Haha


It's funny... but it's really not... but it is though.
"Potential has a shelf life." - Margaret Atwood

Jeff H

  • Needs a day job
  • Posts: 5705
Re: XREF MText Background Shown As Solid Fill?
« Reply #16 on: January 05, 2017, 12:44:23 pm »
Did you find a solution for this.


A user here is having the same problem. It does not do this on my system(I think it use to) but does on another users computer.

BlackBox

  • King Gator
  • Posts: 3735
Re: XREF MText Background Shown As Solid Fill?
« Reply #17 on: January 05, 2017, 01:07:58 pm »
Did you find a solution for this.


A user here is having the same problem. It does not do this on my system(I think it use to) but does on another users computer.

Yes, the solution (for me) - was to not use an incomplete feature that Autodesk still has not fixed.


Cheers
"Potential has a shelf life." - Margaret Atwood

Jeff H

  • Needs a day job
  • Posts: 5705
Re: XREF MText Background Shown As Solid Fill?
« Reply #18 on: January 08, 2017, 02:52:49 pm »
I got it fixed.
Had to start Autodesk desktop App and a hotfix showed up that fixed it.