Author Topic: !! BIGBUG AutoCAD !!  (Read 8476 times)

0 Members and 1 Guest are viewing this topic.

Andrea

  • Water Moccasin
  • Posts: 2372
!! BIGBUG AutoCAD !!
« on: September 20, 2004, 05:39:27 PM »
Hi,

Is this normal !!!!???

Open a new drawing and save-it,
this will be around 25ko file size.

If you make qsave many times (50 approx)
without drawing anything and without zooming...
just qsave.

and than take a look of your AutoCAD drawing size.

this will be more than 25ko.....

WHY ???

also, we can not purge and/or audit....

so if you are in a existing BIG drawing and make a simple
Wblock containing 2 lines.....take a look of this Wblock file size....

IS THIS NORMAL ???

Any information about this will be appreciated.

thanks.
Keep smile...

hyposmurf

  • Guest
!! BIGBUG AutoCAD !!
« Reply #1 on: September 20, 2004, 06:12:32 PM »
Ive saved a blank drawing and it dont seem to increase in size no matter how many times I do a Qsave.

Andrea

  • Water Moccasin
  • Posts: 2372
!! BIGBUG AutoCAD !!
« Reply #2 on: September 20, 2004, 06:16:32 PM »
hmmm.....this is strange.....

wath version of AutoCAD are u using ??

I have tried with 2002 and 2004..and it's the same thing.
also, i have unloaded all lisp routines before with a new template.


tell me more.

tx.
Keep smile...

Keith™

  • Villiage Idiot
  • Seagull
  • Posts: 16899
  • Superior Stupidity at its best
!! BIGBUG AutoCAD !!
« Reply #3 on: September 20, 2004, 06:17:55 PM »
Version?
Addons?
O/S?
Loaded lisp?
Loaded Arx?
Loaded VBA?
too many variables unknown to try and duplicate
Proud provider of opinion and arrogance since November 22, 2003 at 09:35:31 am
CadJockey Militia Field Marshal

Find me on https://parler.com @kblackie

hyposmurf

  • Guest
!! BIGBUG AutoCAD !!
« Reply #4 on: September 20, 2004, 06:20:05 PM »
2000 & 2004,thats what I thought, it maybe an add in program other than vanilla CAD.

Keith™

  • Villiage Idiot
  • Seagull
  • Posts: 16899
  • Superior Stupidity at its best
!! BIGBUG AutoCAD !!
« Reply #5 on: September 20, 2004, 06:23:44 PM »
well I tried it in 2000, 2002, & 2004 and the file actually reduced in size in 2004 from the first save.
Proud provider of opinion and arrogance since November 22, 2003 at 09:35:31 am
CadJockey Militia Field Marshal

Find me on https://parler.com @kblackie

SMadsen

  • Guest
!! BIGBUG AutoCAD !!
« Reply #6 on: September 20, 2004, 06:42:15 PM »
Seen it happening before .. but only with 3rd party apps installed.

Keith™

  • Villiage Idiot
  • Seagull
  • Posts: 16899
  • Superior Stupidity at its best
!! BIGBUG AutoCAD !!
« Reply #7 on: September 20, 2004, 06:48:58 PM »
Quote from: SMadsen
Seen it happening before .. but only with 3rd party apps installed.

That is what I was thinking
Proud provider of opinion and arrogance since November 22, 2003 at 09:35:31 am
CadJockey Militia Field Marshal

Find me on https://parler.com @kblackie

Serge J. Gianolla

  • Guest
!! BIGBUG AutoCAD !!
« Reply #8 on: September 20, 2004, 08:17:42 PM »
Check your ISavePercent variable!

Andrea

  • Water Moccasin
  • Posts: 2372
!! BIGBUG AutoCAD !!
« Reply #9 on: September 21, 2004, 09:33:33 AM »
Quote from: Serge J. Gianolla
Check your ISavePercent variable!


what is the ISavePercent supposed to be ??
default is 50
Keep smile...

sinc

  • Guest
!! BIGBUG AutoCAD !!
« Reply #10 on: September 21, 2004, 11:41:32 AM »
It's a user preference - i.e., the correct setting is whatever works best for you.

Most computers are so fast these days that, unless you work with really large drawings, you can set it to 0.

ronjonp

  • Needs a day job
  • Posts: 7531
!! BIGBUG AutoCAD !!
« Reply #11 on: September 21, 2004, 02:44:03 PM »
Andrea,

Try saving the drawing with this:

Code: [Select]
(defun C:sa (/ isav ibak rast)
  (setq isav   (getvar 'isavepercent)
ibak  (getvar 'isavebak)
rast   (getvar 'rasterpreview)
  )
  (setvar "isavepercent" 100)
  (setvar "isavebak" 0)
  (setvar "rasterpreview" 0)
  (command "qsave")
  (setvar "isavepercent" isav)
  (setvar "isavebak" ibak)
  (setvar "rasterpreview" rast)
)

Windows 11 x64 - AutoCAD /C3D 2023

Custom Build PC

hyposmurf

  • Guest
!! BIGBUG AutoCAD !!
« Reply #12 on: September 21, 2004, 06:21:53 PM »
imcremental save percentage
I used to have mine set to 100 noiw have set to 0,Im still a bit miffed as to what is best. :roll:

Andrea

  • Water Moccasin
  • Posts: 2372
!! BIGBUG AutoCAD !!
« Reply #13 on: September 23, 2004, 10:32:18 AM »
i have set the Isavepercent to 100 and to 1 and to 0

but i can'T see the difference.

any help ??
Keep smile...

sinc

  • Guest
!! BIGBUG AutoCAD !!
« Reply #14 on: September 23, 2004, 03:36:07 PM »
Like I said, with computer speeds as fast as they are these days, you're unlikely to notice any improvement by increasing this value.

Try this.  Set it to 100, and leave it there for a while.  Next week, set it to 0, and open and resave some of the drawings you've been working on.  If you now go into Windows Explorer and start looking at file sizes, I think you'll notice that most of your files are now significantly smaller than the corresponding .bak files.

higher isavepercent = faster saves + bigger files on disk
lower isavepercent = slower save + smaller files on disk

Since the difference in save speed between "fast" and "slow" is generally no longer noticeable, you probably want it set to 0....

hyposmurf

  • Guest
!! BIGBUG AutoCAD !!
« Reply #15 on: September 23, 2004, 03:47:04 PM »
Quote from: Keith
Quote from: SMadsen
Seen it happening before .. but only with 3rd party apps installed.

That is what I was thinking

OK how would he go about doing this?Use the default AutoCAD profile go unload his applications via appload,set demandload to 0,then try it with the default AutoCAD template file?

Keith™

  • Villiage Idiot
  • Seagull
  • Posts: 16899
  • Superior Stupidity at its best
!! BIGBUG AutoCAD !!
« Reply #16 on: September 23, 2004, 10:30:19 PM »
My first guess would be to create a drawing with no template...test it there.... if it still offends .... unload all of the arx modules you can... make sure all of the lisp programs are unloaded and set isavepercent to 0 ....
Proud provider of opinion and arrogance since November 22, 2003 at 09:35:31 am
CadJockey Militia Field Marshal

Find me on https://parler.com @kblackie

hyposmurf

  • Guest
!! BIGBUG AutoCAD !!
« Reply #17 on: September 24, 2004, 06:00:13 PM »
Add on programs would seem more likely but any chance its a virus doing this to his files?Is it only AutoCAD files its affecting?

Keith™

  • Villiage Idiot
  • Seagull
  • Posts: 16899
  • Superior Stupidity at its best
!! BIGBUG AutoCAD !!
« Reply #18 on: September 24, 2004, 08:04:39 PM »
There has been only one instace that I have ever heard of where a virus was specifically attacking AutoCAD drawings...and it has been some time ago.
Proud provider of opinion and arrogance since November 22, 2003 at 09:35:31 am
CadJockey Militia Field Marshal

Find me on https://parler.com @kblackie