Author Topic: Save = crash and no save  (Read 3889 times)

0 Members and 1 Guest are viewing this topic.

McRojo the Irishman

  • Guest
Save = crash and no save
« on: March 11, 2004, 06:22:30 PM »
I've got a problem that is about to make me quit (so they don't fire me).  

I've worked in this office for just about three years, now.  Over the past year or so I've been working my way into Job Captain.  One major roadblock I've been facing in this time is a serious question about the work I do: that I've missed redlines that are highlighted as being done.  For a while I thought I was doing something wrong.  Then I noticed strange things happening.  

First... Occasionally, when I save, AutoCAD closes and any amount of work I've done has not been saved.  It doesn't matter if the drawing has been open five minutes or five hours.  When it happens, all work I have done since the file has been open is lost.  It has happened either using ctrl-s, 'Save' from the pulldown, or type 'Save' at the command prompt.  The .bak file seems to be random so far as the timing it gets saved and is never the completed work when the file is converted to a .dwg.

Second... There are times when someone will see me do the work, watch me save, and the next time the drawing is opened, the work is not done.  Care is taken that the correct drawing is open and saved to the right path.  

Third... There are times when what is on the screen is not what is plotted.  What gets plotted is the previous version of the file.

I don't freaking get it and I'm about to make a major change in my career path!  I've got people yelling at me, the IT guy's don't know what to do, if they can get past the smirks when I bring it up.

If you know me at all, you know I'm good for a shiny new nickle for the help.

daron

  • Guest
Save = crash and no save
« Reply #1 on: March 11, 2004, 06:39:33 PM »
State your computer specs: i.e. type, OS, graphics cards, cad version, add-on packages, etc. Anything that can help.

McRojo the Irishman

  • Guest
Save = crash and no save
« Reply #2 on: March 11, 2004, 06:44:29 PM »
ACAD 2002, Windows XP, IBM, don't know much else.  The company doesn't give us that much info.

M-dub

  • Guest
Save = crash and no save
« Reply #3 on: March 11, 2004, 10:43:36 PM »
It's been a while since I've seen the likes of you, McRojo!  Did you happen to go to IT last summer?

Anyway, need I ask if a reinstall was done?  That would be my first guess.  How about savetime?  Does that save?  Have a look at your .ac$ files, if there are any.  Is it happening to anyone else in the office?  could it be a permissions issue?  Is there any kind of a pattern to this problem?  What happens if you copy the drawing to your hard drive, then try to save it.  You say this happens Occasionally, which seems very odd.

I dunno...I'd try another reinstall and possibly ask for a new computer (I know, I know...They'll just laugh their way out of your office) but if all else fails, FORMAT C:

Good Luck!
Mike

Keith™

  • Villiage Idiot
  • Seagull
  • Posts: 16899
  • Superior Stupidity at its best
Save = crash and no save
« Reply #4 on: March 11, 2004, 11:08:46 PM »
My first guess would be a drawing management system gone awry... If it is indeed a non-saving issue, try these little tricks...
Repath the autosave path to an easily accessable folder, such as C:\autosave (make sure it exists)
set up the autosave to make backups instead of overwriting the files.
Ensure that you are not saving to a previous version of AutoCAD.
Set your savetime to something like 10 minutes if the files are relatively large (or like 3 minutes if they are somewhat small)
Engage a drawing long enough for it to save the drawing a few times with autosave...
Ensure that the drawing is being autosaved...
rename the saved drawing from xxxxx.bk1 to xxxxx.dwg and see if the changes are there....
Ensure you are not using partial open OR incremental save (I have heard of these features having unpredictable results)
Run an audit on the offending documents.
WBlock the drawing to a new drawing and see if the entities made the transition.
Ensure you do not have a background "on save" reactor running that cancels your save command. These can be embedded in VBA, VLisp and ARX modules. I would suggest that if you save the file and then try to reopen it immediately (without closing the original one)  it will open as read only... if it is not all there, then unload all of your ARX modules and then close the read only drawing and try the save again......
If all else fails... kill the computer and tell them it was a hard drive error all along....
Proud provider of opinion and arrogance since November 22, 2003 at 09:35:31 am
CadJockey Militia Field Marshal

Find me on https://parler.com @kblackie

Spageddie

  • Guest
Save = crash and no save
« Reply #5 on: March 12, 2004, 01:04:13 AM »
8) It sounds as if you have read only permissions to the folder containing the drawings.
Try copying/saving as to your local drive and see if it saves ok.

hudster

  • Gator
  • Posts: 2848
Save = crash and no save
« Reply #6 on: March 12, 2004, 03:53:35 AM »
We had the same problem in here, you click save, the progress bar goes along, but close and re-open the drawing and it's back to its original state.

I never found the cause, but I managed to solve it but completely uninstalling AutoCAD and then re-instaling it.

If anyone knows what causes this I'd be interested to find out the cure.
Revit BDS 2017, 2016, 2015, 2014, AutoCAD 2017, 2016, Navisworks 2017, 2016, BIM360 Glue

hendie

  • Guest
Save = crash and no save
« Reply #7 on: March 12, 2004, 04:12:16 AM »
Keith's first guess was my first guess also.... but that falls down since you don't seem to be using any kind of DMS.

This may be completely wrong but it may have something to do with your network. I had problems recently with drawings turning read only on me while I was working on them. It baffled me for ages until I found out about how Acad actually works in saving drawings behind the scenes.
(I hope I get this correct...) When you open a drawing, you don't actually open it ~ Acad makes a copy of the drawing, places a lock on the original and opens the copy for you to work on. Every time you save, Acad saves the copy, unlocks the original, overwrites it with the saved copy, and locks the original again.... and so on. During this process, Acad sends a signal back to the original and waits for a response ~if it doesn't get the response in time it "assumes" someone else has got the drawing open and turns the already opened copy to "Read-Only"

Now, my guess is that something is happening in amongst all this saving, copying, signal sending etc and the process is getting mucked up somehow. ~ would you know if there is particularly heavy network traffic when this problem occurs ?

I seem to remember a thread recently which was similar to yours ~ someone was saving drawings but for some reason the contents of files that hadn't been worked on were getting the changes written to them. The "working" files weren't keeping the changes.
I don't know if they ever got it resolved.

I would suggest in the meantime that you plot a copy or do a screen grab of your work every 15 minutes or so and hopefully you'll catch the problem "in action" and be able to prove that you are doing the work but it's getting lost in the network somewhere.