Author Topic: Field not updating in Dynamic block  (Read 269 times)

0 Members and 1 Guest are viewing this topic.

entget

  • Mosquito
  • Posts: 14
Field not updating in Dynamic block
« on: July 19, 2022, 10:44:45 AM »
Hello all,
I have a Dynamic block with a visibility state for each engineer with their seal and a piece of text with a field set to 'todays date'.
When first inserted, it's fine - date comes up as today.
When I save and open the drawing the next day, the field does not update.
Regen, save as, changing visibility state and back again - nothing works.
Fieldeval is set to 31 which is the same as Options>User Preferences>Field Update settings>all checked (right?)

UpdateField does work though... but I'd rather not have to click something to get it to update when update is what it's supposed to do automagically...

What am I missing?
Thoughts?
Thanks!

57gmc

  • Newt
  • Posts: 144
Re: Field not updating in Dynamic block
« Reply #1 on: July 19, 2022, 01:56:53 PM »
I've contacted an AutoCAD product manager about this, and the reply I got was that it is "as designed". They don't have any plan to change it. I have a db with a field in each state pointing to an attribute and it won't update. Its been this way for many years.

entget

  • Mosquito
  • Posts: 14
Re: Field not updating in Dynamic block
« Reply #2 on: July 19, 2022, 02:24:19 PM »
Oof - I was afraid I would hear something like that...
will look into a work around for this 'as designed feature'.

Thanks for the input, take care!

57gmc

  • Newt
  • Posts: 144
Re: Field not updating in Dynamic block
« Reply #3 on: July 19, 2022, 02:39:35 PM »
I was thinking of something different, but I just checked Help and it says that the Date field never updates automatically. It must be updated manually.

entget

  • Mosquito
  • Posts: 14
Re: Field not updating in Dynamic block
« Reply #4 on: July 19, 2022, 03:17:21 PM »
Ha! I'm remembering plot stamps from back in the day using Diesel expressions!

Then I started looking at All Field options ...like system variables - one of which is current date, which works on regen!
...took a long time but I think I've got the fix there.