Author Topic: Navisworks Appearance Profiler not applying color  (Read 9275 times)

0 Members and 1 Guest are viewing this topic.

Krushert

  • Seagull
  • Posts: 13616
  • FREE BEER Tomorrow!!
Navisworks Appearance Profiler not applying color
« on: November 12, 2014, 10:53:32 AM »
Navisworks Manage 2014 Appearance Profiler not applying color to all items in the search set even though the search set is selecting those objects.   I think (a guess here) that the color is hard coded to the Revit Material.   Screen shot below shows pipes that are not coloring but the fitting and valves are.  The pipes are system families in Revit MEP.  I also have this problem with stairs.

Do I have to switch something Revit or do I do it in Navisworks?



I + XI = X is true ...  ... if you change your perspective.

I no longer CAD or Model, I just hang out here for camaraderie

Matt__W

  • Seagull
  • Posts: 12955
  • I like my water diluted.
Re: Navisworks Appearance Profiler not applying color
« Reply #1 on: November 12, 2014, 11:00:10 AM »
Is your view set to FULL RENDER or SHADED?
Autodesk Expert Elite
Revit Subject Matter Expert (SME)
Owner/FAA sUAS Pilot @ http://skyviz.io

Krushert

  • Seagull
  • Posts: 13616
  • FREE BEER Tomorrow!!
Re: Navisworks Appearance Profiler not applying color
« Reply #2 on: November 12, 2014, 11:45:47 AM »
Was in Full Render. Change it to Shaded and the pipes were now color as desired. 

But Shaded mode is not desired.  Will need it in the Full Render Mode.
I + XI = X is true ...  ... if you change your perspective.

I no longer CAD or Model, I just hang out here for camaraderie

Matt__W

  • Seagull
  • Posts: 12955
  • I like my water diluted.
Re: Navisworks Appearance Profiler not applying color
« Reply #3 on: November 12, 2014, 11:54:00 AM »
Why do you have to view it in FULL RENDER mode?  Why not leave it in SHADED mode and create renderings (if need be)?  Shaded mode is a LOT faster to navigate, too.
Autodesk Expert Elite
Revit Subject Matter Expert (SME)
Owner/FAA sUAS Pilot @ http://skyviz.io

Krushert

  • Seagull
  • Posts: 13616
  • FREE BEER Tomorrow!!
Re: Navisworks Appearance Profiler not applying color
« Reply #4 on: November 12, 2014, 12:00:59 PM »
Why do you have to view it in FULL RENDER mode?  Why not leave it in SHADED mode and create renderings (if need be)?  Shaded mode is a LOT faster to navigate, too.

Because of the Client.  The client will be getting the NW Model for their use, AKA to run scenarios on all those yellow points. 
I + XI = X is true ...  ... if you change your perspective.

I no longer CAD or Model, I just hang out here for camaraderie

Matt__W

  • Seagull
  • Posts: 12955
  • I like my water diluted.
Re: Navisworks Appearance Profiler not applying color
« Reply #5 on: November 12, 2014, 01:11:43 PM »
Did the client specifically request the Navisworks model be in realistic mode?  If not, don't give it to them that way.  They stand to gain NOTHING by checking for clashes with materials displayed on everything.  NOTHING.  And like I said before, the overall navigation within the model with be significantly slower in a realistic mode than in the shaded mode.
Autodesk Expert Elite
Revit Subject Matter Expert (SME)
Owner/FAA sUAS Pilot @ http://skyviz.io

Krushert

  • Seagull
  • Posts: 13616
  • FREE BEER Tomorrow!!
Re: Navisworks Appearance Profiler not applying color
« Reply #6 on: November 12, 2014, 01:30:10 PM »
Did the client specifically request the Navisworks model be in realistic mode?  If not, don't give it to them that way.  They stand to gain NOTHING by checking for clashes with materials displayed on everything.  NOTHING.  And like I said before, the overall navigation within the model with be significantly slower in a realistic mode than in the shaded mode.

They did not specifically request it but they do want to differentiate the material of objects.  CMU wall vs Metal Panel vs Plastic.  With Shaded setting, all the walls and steel are the same color.   I am dealing with non-Revit &non-Navisworks users here and I am trying to keep things as simple as possible.  (There will be a bunch of scientists and lawyers over schmuck's shoulder and they will need as much rendering as possible to "guide" them through the model.)  Second I do not want to create a bunch of Appearance Profiles For all the material in the model.  Third I do not care rat's butt about navigation speed for them.   4th there will be no clash detection done.  This is just a pretty picture to them to see what the yellow node is attached to. 
I + XI = X is true ...  ... if you change your perspective.

I no longer CAD or Model, I just hang out here for camaraderie

Matt__W

  • Seagull
  • Posts: 12955
  • I like my water diluted.
Re: Navisworks Appearance Profiler not applying color
« Reply #7 on: November 12, 2014, 01:37:05 PM »
This is just a pretty picture to them to see what the yellow node is attached to.
Then why not simply use Revit?  You can use Revit in viewer mode so you won't need a license.  You'll get all of the materials displaying correctly and you won't have to worry about exporting to a different file format, modifying, etc....  Why complicate things?
Autodesk Expert Elite
Revit Subject Matter Expert (SME)
Owner/FAA sUAS Pilot @ http://skyviz.io

Krushert

  • Seagull
  • Posts: 13616
  • FREE BEER Tomorrow!!
Re: Navisworks Appearance Profiler not applying color
« Reply #8 on: November 12, 2014, 01:43:50 PM »
This is just a pretty picture to them to see what the yellow node is attached to.
Then why not simply use Revit?  You can use Revit in viewer mode so you won't need a license.  You'll get all of the materials displaying correctly and you won't have to worry about exporting to a different file format, modifying, etc....  Why complicate things?
Just because!
I + XI = X is true ...  ... if you change your perspective.

I no longer CAD or Model, I just hang out here for camaraderie

Matt__W

  • Seagull
  • Posts: 12955
  • I like my water diluted.
Re: Navisworks Appearance Profiler not applying color
« Reply #9 on: November 12, 2014, 01:46:42 PM »
...
Autodesk Expert Elite
Revit Subject Matter Expert (SME)
Owner/FAA sUAS Pilot @ http://skyviz.io

Krushert

  • Seagull
  • Posts: 13616
  • FREE BEER Tomorrow!!
Re: Navisworks Appearance Profiler not applying color
« Reply #10 on: November 12, 2014, 01:57:57 PM »
 :2funny: :2funny: :2funny:

my feelings towards you as well.   

To properly explain this project, it will have to be over discussion that consist of more beer that I owe you now. 
I + XI = X is true ...  ... if you change your perspective.

I no longer CAD or Model, I just hang out here for camaraderie

Krushert

  • Seagull
  • Posts: 13616
  • FREE BEER Tomorrow!!
Re: Navisworks Appearance Profiler not applying color
« Reply #11 on: November 12, 2014, 02:22:19 PM »
So if I go into Revit and into the stair family, toggle the material to "By Category".  ReExport to NW and then run Profiler, the stairs will color as desired.  But It screws over my Revit model in properly showing the material there.  Dam if I do ~ Dam if I don't

I + XI = X is true ...  ... if you change your perspective.

I no longer CAD or Model, I just hang out here for camaraderie

Krushert

  • Seagull
  • Posts: 13616
  • FREE BEER Tomorrow!!
Re: Navisworks Appearance Profiler not applying color
« Reply #12 on: November 13, 2014, 01:51:51 PM »
So I fixed the stairs but dammed if I can find where I can control the material for Pipes in Revit MEP. 

So I decided to stop fighting and just change the fittings to match the pipes using the Appearance Profiler. I am bummed that I could not get use the pink fuchsia.   :-P
I + XI = X is true ...  ... if you change your perspective.

I no longer CAD or Model, I just hang out here for camaraderie

Matt__W

  • Seagull
  • Posts: 12955
  • I like my water diluted.
Re: Navisworks Appearance Profiler not applying color
« Reply #13 on: November 13, 2014, 01:58:25 PM »
So I fixed the stairs but dammed if I can find where I can control the material for Pipes in Revit MEP. 
Manage --> Object Styles will control the material on a global basis.
Autodesk Expert Elite
Revit Subject Matter Expert (SME)
Owner/FAA sUAS Pilot @ http://skyviz.io

Matt__W

  • Seagull
  • Posts: 12955
  • I like my water diluted.
Re: Navisworks Appearance Profiler not applying color
« Reply #14 on: November 13, 2014, 02:01:28 PM »
OR.... you can scroll down to the Families section of the Project Browser and locate the Piping Systems section.  From there you can change the material of entire systems.
Autodesk Expert Elite
Revit Subject Matter Expert (SME)
Owner/FAA sUAS Pilot @ http://skyviz.io

John Kaul (Se7en)

  • Administrator
  • Needs a day job
  • Posts: 9521
Re: Navisworks Appearance Profiler not applying color
« Reply #15 on: November 13, 2014, 02:03:58 PM »
So I fixed the stairs but dammed if I can find where I can control the material for Pipes in Revit MEP. 

OR.... you can scroll down to the Families section of the Project Browser and locate the Piping Systems section.  From there you can change the material of entire systems.

^^ Here's a pic (I was making it while you decided to beat me to the punch by using words). :P
TheSwamp.org (serving the CAD community since 2003)

Donate to TheSwamp.org