Author Topic: Radial Menu  (Read 13602 times)

0 Members and 1 Guest are viewing this topic.

reltro

  • Guest
Re: Radial Menu
« Reply #75 on: August 30, 2014, 03:36:02 AM »
No start.

Code: [Select]
Command: DRAW-MODIFY
>>> type shortcut [?] OR <Line>: Grread-loop: bad argument type: lentityp nil;
error: An error has occurred inside the *error* functionAutoCAD variable
setting rejected: "CMDECHO" nil
Command:

I test in 2010.
BTW. What is the difference between  DRAW-MODIFY 3.0b.

Hm, ok... I have to investigate this... =( will be back soon...
The difference to 3.0b is that the wipeouts in this version are drawn in the right place in all UCS and Views, except 3D-Views...

greets reltro

reltro

  • Guest
Re: Radial Menu
« Reply #76 on: August 30, 2014, 03:50:41 AM »
@emk2012

I reattached the file above. It may be the same error with entmakex like in the previous version of V3...
Can u test it please?

greets reltro

andy_lee

  • Newt
  • Posts: 147
Re: Radial Menu
« Reply #77 on: August 30, 2014, 04:02:54 AM »
@emk2012

I reattached the file above. It may be the same error with entmakex like in the previous version of V3...
Can u test it please?

greets reltro


Command: draw-modify
>>> type shortcut [?]: Grread-loop: no function definition:
VLA-PUT-ENTITYTRANSPARENCY
Command:
Command: draw-modify
>>> type shortcut [?]: Grread-loop: no function definition:
VLA-PUT-ENTITYTRANSPARENCY
andy.
Best regards.

reltro

  • Guest
Re: Radial Menu
« Reply #78 on: August 30, 2014, 04:11:37 AM »
Command: draw-modify
>>> type shortcut [?]: Grread-loop: no function definition:
VLA-PUT-ENTITYTRANSPARENCY
Command:
Command: draw-modify
>>> type shortcut [?]: Grread-loop: no function definition:
VLA-PUT-ENTITYTRANSPARENCY

All right... so in ACAD2010 is no transparency? did know this...

Reattached it above...

greets reltro

BTW: thanks for ur tests :)

andy_lee

  • Newt
  • Posts: 147
Re: Radial Menu
« Reply #79 on: August 30, 2014, 04:44:16 AM »

All right... so in ACAD2010 is no transparency? did know this...
Reattached it above...
greets reltro
BTW: thanks for ur tests :)

Great Job! thanks for sharing.
Now ,is OK ,  Can see Interface, can operate.
But , When the operation is complete .
A message appears
Command: ; error: bad argument type: lentityp nil

Code: [Select]
Command:  DRAW-MODIFY
>>> type shortcut [?] OR <Circle>: _.circle Specify center point for circle or
[3P/2P/Ttr (tan tan radius)]:
Specify radius of circle or [Diameter] <310.1726>: 10
Command: ; error: bad argument type: lentityp nil

eg. draw a cicle .pickup center point,  Specify radius of circle,  circle is draw complete.
but Still tip: Command: ; error: bad argument type: lentityp nil
andy.
Best regards.

reltro

  • Guest
Re: Radial Menu
« Reply #80 on: August 30, 2014, 04:57:35 AM »
Hm ok...
This is strange... I can not reproduce the error. Would be nice if u can help me to find the error.

Can u run some test?
01:  run the Menu, then press F9 (toggles Off the wipeouts) and then draw a circle?
02: Same above just with F7 (toggles Off the Title-Override)
03: Same above just with F8 (toggles Off the mouseover-action)

greets reltro

andy_lee

  • Newt
  • Posts: 147
Re: Radial Menu
« Reply #81 on: August 30, 2014, 05:06:13 AM »
Hm ok...
This is strange... I can not reproduce the error. Would be nice if u can help me to find the error.

Can u run some test?
01:  run the Menu, then press F9 (toggles Off the wipeouts) and then draw a circle?
02: Same above just with F7 (toggles Off the Title-Override)
03: Same above just with F8 (toggles Off the mouseover-action)

greets reltro


I test with lisp editor. but code is too big.  Now , Stops responding. :cry:
andy.
Best regards.

andy_lee

  • Newt
  • Posts: 147
Re: Radial Menu
« Reply #82 on: August 30, 2014, 05:11:27 AM »
toggles Off the wipeouts  , test .is the same.
toggles Off the Title-Override , test . is the same.
toggles Off the mouseover-action ,test .is the same.

Is the same.
Command: ; error: bad argument type: lentityp nil
andy.
Best regards.

andy_lee

  • Newt
  • Posts: 147
Re: Radial Menu
« Reply #83 on: August 30, 2014, 06:33:17 AM »
@ reltro
I test in AutoCAD Mechanical 2013,  is same too. (another comptuer, intel xeon E31235 , 16G RAM) ,

Code: [Select]
Command: ; error: bad argument type: lentityp nil
andy.
Best regards.

reltro

  • Guest
Re: Radial Menu
« Reply #84 on: August 30, 2014, 06:38:37 AM »
Hey emk2012...

Thanks for ur tests... I'm not sure were this error happens, so its dig-into-time.
As u said the vlide can not handle, its going to be hard to find... have to install an other acad... now running 2014, and all works good...
Im not sure why the vlide can't handle it. Maybe its a problem that most of the code is written during the runtime... Could it be?

Will be back soon, I hope... :|

greets reltro