Author Topic: Dynamic Block Property Issue  (Read 953 times)

0 Members and 1 Guest are viewing this topic.

TruthWarrior17

  • Guest
Dynamic Block Property Issue
« on: May 18, 2009, 11:41:21 AM »
I am having an issue where I insert a dynamic block into a drawing after programmatically changing one of its properties. The block has scaled accordingly but now the grips no longer scale the block and changing the property in the properties palette does nothing more than move the grips to where they should be but the block still stays the same. This only happens when the property is changed programmatically. When i move the block by its base point, AutoCAD shows the preview image(I'm guessing they use a jig) in the size that the block is supposed to be according to the grips and the property but when I click again to place the block in the new location, it stays the incorrect size.  Anyone have ideas on how to fix this?

Update: If I edit the property after adding the block to the model space block table record, it eliminates the issue.  Next Step - make the jig show the block scaled properly.
« Last Edit: May 18, 2009, 12:37:30 PM by TruthWarrior17 »

Glenn R

  • Water Moccasin
  • Posts: 1932
  • What idiot child of married cousins wrote this?!
Re: Dynamic Block Property Issue
« Reply #1 on: May 18, 2009, 04:18:29 PM »
Without some key pieces of information like:

AutoCAD version
Visual Studio version
.NET Framework version
Example code

I'd only be guessing. Having said that, have you tried issuing the REGENALL command and see if the graphics update? If so, then it's an updating issue.
Me