Author Topic: custom pallett icons not showing  (Read 1860 times)

0 Members and 1 Guest are viewing this topic.

CottageCGirl

  • Guest
custom pallett icons not showing
« on: May 12, 2009, 08:49:34 AM »
ADT 08   ---
I have finally completed all my custom palletts .....sucessfully shared custom catalogs on other workstations.....but I have one pallett w/ custom icons that are not showing up...the text is there and they work..just no icons...I have the bmp's in a folder on the network, and put that path in Options/ files/ support file search path... :?

mjfarrell

  • Seagull
  • Posts: 14444
  • Every Student their own Lesson
Re: custom pallett icons not showing
« Reply #1 on: May 12, 2009, 08:53:01 AM »
If you move or copy a toolbar from one .cui file to another, the toolbar icons may not appear correctly in the new CUI. To work correctly, the .dll file that contains the toolbar bitmaps must have the same name as the .cui file.

For example, if you move or copy a toolbar from civil.cui to custom.cui, you must make a copy of civil.dll and name it custom.dll. These bitmap .dll files are located in the same folder as the .cui files: C:\Documents and Settings\<your login name>\Application Data\Autodesk\C3D 2007\enu\Support.

Be your Best


Michael Farrell
http://primeservicesglobal.com/

CottageCGirl

  • Guest
Re: custom pallett icons not showing
« Reply #2 on: May 12, 2009, 08:58:39 AM »
If you move or copy a toolbar from one .cui file to another, the toolbar icons may not appear correctly in the new CUI. To work correctly, the .dll file that contains the toolbar bitmaps must have the same name as the .cui file.

For example, if you move or copy a toolbar from civil.cui to custom.cui, you must make a copy of civil.dll and name it custom.dll. These bitmap .dll files are located in the same folder as the .cui files: C:\Documents and Settings\<your login name>\Application Data\Autodesk\C3D 2007\enu\Support.



thanks...think i get it...will try it :-)

Draftek

  • Guest
Re: custom pallett icons not showing
« Reply #3 on: May 12, 2009, 09:15:19 AM »
Tool palettes are not part of the CUI scheme.

When you create them the path to the bitmaps are embedded into the xml file. (.cat). Usually it's a relative path scheme.

You may try adding that path to the tool palettes path in options, not as a support path.