Author Topic: Attributes in block, but not showing in Block editor  (Read 10826 times)

0 Members and 1 Guest are viewing this topic.

Keith™

  • Villiage Idiot
  • Seagull
  • Posts: 16812
  • Superior Stupidity at its best
Re: Attributes in block, but not showing in Block editor
« Reply #15 on: April 14, 2008, 09:35:56 AM »
Tracey, the attributes in this title block were evidently added after the block was created. Unfortunately unless you have a program to add them back to the block reference, you won't be able to have the attributes available for insertion into a new drawing.
ATTSYNC?
Nope .. no attributes in the block to sync
Proud provider of opinion and arrogance since November 22, 2003 at 09:35:31 am
CadJockey Militia Field Marshal

Kate M

  • Guest
Re: Attributes in block, but not showing in Block editor
« Reply #16 on: April 14, 2008, 12:03:17 PM »
Tracey, the attributes in this title block were evidently added after the block was created. Unfortunately unless you have a program to add them back to the block reference, you won't be able to have the attributes available for insertion into a new drawing.
ATTSYNC?
Nope .. no attributes in the block to sync
If the block was created, and then attributes were added, ATTSYNC should push them out to all instances of the block. If the block was created with attributes, and they were subsequently removed, ATTSYNC would remove them from all instances.

It sounds like Tracey's situation may have been case 2? (Although I haven't investigated the drawing.)

Keith™

  • Villiage Idiot
  • Seagull
  • Posts: 16812
  • Superior Stupidity at its best
Re: Attributes in block, but not showing in Block editor
« Reply #17 on: April 14, 2008, 12:18:40 PM »
I opened the block, it would appear as though it were a pasted reference with attached attributes, thus they were never defined int he block to begin with. ATTSYNC will remove the attributes from all blocks.
Proud provider of opinion and arrogance since November 22, 2003 at 09:35:31 am
CadJockey Militia Field Marshal

CADaver

  • Guest
Re: Attributes in block, but not showing in Block editor
« Reply #18 on: April 14, 2008, 07:40:59 PM »
I opened the block, it would appear as though it were a pasted reference with attached attributes, thus they were never defined int he block to begin with. ATTSYNC will remove the attributes from all blocks.
Sounds like the current definition has no attributes, but a previous definition did... bummer.

svorgodne

  • Mosquito
  • Posts: 1
Re: Attributes in block, but not showing in Block editor
« Reply #19 on: October 08, 2020, 10:21:13 AM »
Very old post, but I think I found the mistake.

Yet I want to know if there is somebody with the solution.

The problem is that the block itself has a nested block with the same name, which contains the attributes. It is not possible to see them by using the block editor. I was able to see it when I used the refedit command, then I could see the the attributes in the background, so I listed it and it has the same name.

Attached an example of one file I was working on with the same mistake

Greets