Author Topic: Protected Symbol: acNative - Message  (Read 2828 times)

0 Members and 1 Guest are viewing this topic.

LE3

  • Guest
Protected Symbol: acNative - Message
« on: September 13, 2010, 02:42:41 PM »
I am getting the below message (or see attached image):
Assignment to protected symbol:
acNative
Enter to break loop?

This happens after a call (vl-load-com) inside of AutoCAD 2010 (I have installed 2009, 2010 and 2011 if does a difference)
Now, I used to simple get rid of this type of message by using, something like:

(pragma   '((unprotect-assign acNative)))
... do my stuff...
(pragma   '((protect-assign acNative)))

But the above does not work because the symbol does not exist... for now I can live by clicking on the 'No' button, anyone seen and resolve this?

Thanks!

kpblc

  • Bull Frog
  • Posts: 322
Re: Protected Symbol: acNative - Message
« Reply #1 on: September 13, 2010, 02:49:41 PM »
Do you use AutoCAD 2010 64 bit? I've got the same error on 64-bit AutoCAD. ServicePack didn't solve this problem :( The only way i found is press "No" and continue working...
P.S. This message won't appear within AutoCAD 2010 (32 bit) on 32-bit Windows. I didn't test 32-bit AutoCAD on 64-bit OS :(
P.P.S. sorry for my English.
Sorry for my English.

LE3

  • Guest
Re: Protected Symbol: acNative - Message
« Reply #2 on: September 13, 2010, 02:52:57 PM »
Do you use AutoCAD 2010 64 bit? I've got the same error on 64-bit AutoCAD. ServicePack didn't solve this problem :( The only way i found is press "No" and continue working...
P.S. This message won't appear within AutoCAD 2010 (32 bit) on 32-bit Windows. I didn't test 32-bit AutoCAD on 64-bit OS :(
P.P.S. sorry for my English.
Thanks you.

This happen on my 32 bit machine - have also the 64 bit version, but only use that machine for testings.

And yes, only happens with A2010 :-(

Lee Mac

  • Seagull
  • Posts: 12267
  • London, England
Re: Protected Symbol: acNative - Message
« Reply #3 on: September 13, 2010, 03:09:14 PM »
The acNative is an enum for the vla-saveas method - do you have a LISP in startup that is perhaps trying to redefine it? Just a thought.

LE3

  • Guest
Re: Protected Symbol: acNative - Message
« Reply #4 on: September 13, 2010, 03:12:49 PM »
The acNative is an enum for the vla-saveas method - do you have a LISP in startup that is perhaps trying to redefine it? Just a thought.
Yep,... and nope there is nothing that use that symbol in particular, have run a search in all the files here and nada (nothing).


Kerry

  • Mesozoic relic
  • Seagull
  • Posts: 11654
  • class keyThumper<T>:ILazy<T>
Re: Protected Symbol: acNative - Message
« Reply #5 on: September 13, 2010, 05:54:14 PM »
acNative
Is a synonym for the latest drawing release. 

Quote

namespace Autodesk.AutoCAD.Interop.Common
{
    using System;
    using System.Runtime.InteropServices;

    [Guid("5BC4EECD-F0D4-4738-AD57-3DF8842CCB40")]
    public enum AcSaveAsType
    {
        ac2000_dwg = 12,
        ac2000_dxf = 13,
        ac2000_Template = 14,
        ac2004_dwg = 0x18,
        ac2004_dxf = 0x19,
        ac2004_Template = 0x1a,
        ac2007_dwg = 0x24,
        ac2007_dxf = 0x25,
        ac2007_Template = 0x26,
        acNative = 0x24,
        acR12_dxf = 1,
        acR13_dwg = 4,
        acR13_dxf = 5,
        acR14_dwg = 8,
        acR14_dxf = 9,
        acR15_dwg = 12,
        acR15_dxf = 13,
        acR15_Template = 14,
        acR18_dwg = 0x18,
        acR18_dxf = 0x19,
        acR18_Template = 0x1a,
        acUnknown = -1
    }
}

Perfection is not optional.
Everything will work just as you expect it to, unless your expectations are incorrect.
Discipline: None at all.

--> Donate to theSwamp<--

LE3

  • Guest
Re: Protected Symbol: acNative - Message
« Reply #6 on: September 13, 2010, 06:13:15 PM »
Thank you Kerry.

Just to double check on this issue here:

If I launch VLIDE and type acNative it does not shown in blue - until a call to (vl-load-com)

...  :-(

acNative
Is a synonym for the latest drawing release. 

Quote

namespace Autodesk.AutoCAD.Interop.Common
{
    using System;
    using System.Runtime.InteropServices;

    [Guid("5BC4EECD-F0D4-4738-AD57-3DF8842CCB40")]
    public enum AcSaveAsType
    {
        ac2000_dwg = 12,
        ac2000_dxf = 13,
        ac2000_Template = 14,
        ac2004_dwg = 0x18,
        ac2004_dxf = 0x19,
        ac2004_Template = 0x1a,
        ac2007_dwg = 0x24,
        ac2007_dxf = 0x25,
        ac2007_Template = 0x26,
        acNative = 0x24,
        acR12_dxf = 1,
        acR13_dwg = 4,
        acR13_dxf = 5,
        acR14_dwg = 8,
        acR14_dxf = 9,
        acR15_dwg = 12,
        acR15_dxf = 13,
        acR15_Template = 14,
        acR18_dwg = 0x18,
        acR18_dxf = 0x19,
        acR18_Template = 0x1a,
        acUnknown = -1
    }
}



Kerry

  • Mesozoic relic
  • Seagull
  • Posts: 11654
  • class keyThumper<T>:ILazy<T>
Re: Protected Symbol: acNative - Message
« Reply #7 on: September 13, 2010, 07:51:47 PM »

Yes Luis,
I believe that is the case with all of the COM variables/enumerators.
Perfection is not optional.
Everything will work just as you expect it to, unless your expectations are incorrect.
Discipline: None at all.

--> Donate to theSwamp<--